Digital Solutions
iDigole Buyer ProtectioniDigole Buyer
My shopping cart
0 Items:
Secure Checkout
Top Rated Plus
Visit Our Live Auctions
99.9% Customer's Satisfaction
Search store:
Forum : Digole Serial Display :

 Search Forum.. 
 Creat New Topic   Reply 

Loading Firmware

While writing to the flash memory I managed to make my screen completley unresponsive. It would turn on with a black screen, but commands would do nothing. I figured flashing the firmware would help, it originally had 4.1 on it so I chose 4.2. Since it's unresponsive to commands I had to do the "hard" reset and managed to get the "S" to appear in coolterm. I uploaded the firmware and got a "G" response in the terminal. The screen is back to doing the color cycling on boot up, but then it goes back to the black screen and is unresonsive again.

RE:Loading Firmware

Your display supposed be 2.4" color IPS? this display have few generations till now, please provide the PCB version where you can find it on the component side first.
sorry forgot: 2 inch TFT also have 2 versions.

Also, according to your description, the display may running splash screen data from on board flash chip, but the data on the chip are junk, so, it may drive the display run it for a long time or even indefinitely, you can wait a little bit long to see if the display come back, then disable the splash screen (start screen), or remove the on board flash chip. If you want to reuse the flash, you need to erase the data at the address 0 at least, or erase whole chip.

RE:Loading Firmware

It is the 2.6" IPS.

I suspect that is what's happening, but I thought if I flashed the firmware it would go back to the original start screen. Is the default start screen's command set stored at 0 on the flash? I suppose that would explain why it continues to lock up.

The flash chip is the Winbond 25Q128FVSG, correct? In my attempts to avoid having to remove the chip I tried to pull the chip select high, but the display doesn't boot at all, I suspect that's because it's waiting for a response from the flash chip. Then I tried installing the non-flash firmware, but the bootloader refused it with an "N" response.

So I wired up the SPI bus on the chip while still on the board and connected it to an arduino. I put the display in bootloader mode (I assume it doesn't communicate with the flash chip in this state) and used the arduino to erase the flash memory, reading from the flash shows me blanked out memory. When I reboot the display it does the exact same thing and when I go back in with the arduino there is now garbage data back on the flash, this data changes every time the display is power cycled.

RE:Loading Firmware

1) reflash the firmware won't change the data in flash chip, so, the junk data of start screen still there

2) you can use any WINDBOND 25Q flash from 8Mb to 256Mb, if you want to reflash the display without flash chip, you need open the firmware that downloaded from our site with text editor, change the first line "CF" to "D0", save it. then you can use it to reflash the display.

3) there is not writing flash chip code in the firmware when power up, it seems something wrong in your case.

RE:Loading Firmware

Okay that worked to get non-flash chip firmware to work. The internal 16kb is more than enough for my purposes anyway.

I just ordered another one with external flash since I wasn't sure if this was going to be recoverable (and I plan on using it later anyway). I want to clarify for future reference, does the default start screen run a command set that starts at 0 in flash memory? So, to avoid this sort of thing in the future it would be a good idea to start at something like address 16384 to always make the display recoverable in the event of a bad write?

Copyright Digole Digital Solutions, 2008-2021. All rights reserved.
Powered by Victor Sun