Digital Solutions
iDigole Buyer ProtectioniDigole Buyer
My shopping cart
0 Items:
Secure Checkout
Top Rated Plus
Visit Our Live Auctions
99.9% Customer's Satisfaction
Search store:
Forum : Digole Serial Display :

 Search Forum.. 
 Creat New Topic   Reply 

Touch panel in 2.4, 2.6 TFT doesn't work at all !

Hi guys,

maybe someone of you has encountered such a phenomenon :

1. I send through UART command "RPNXYx" to activate touch panel, where "x" is a letter of available options. I have tried all possibilities.

2. On Tx output of module there is no activity at all.

To be sure that my hardware doesn't influence this pin I have disconnected it from module, so I observe this pin on the oscilloscope.

The "Service" says "you have wrong hardware". No, it is OK because other commands like "TT", CL" etc. work. So the module receives

the data correctly.


So I have questions :

a. does this touch panel work at all ?????

b. if it can operate, what an enigmatic trick is necessary to make it operational ?

c. sending to module ASCII codes of these 6 bytes "RPN....." is enough or something must be added (I tried with trailing 0, no change) ?


I have tried all thes options on three modules ! All of them behave the same way !


RE:Touch panel in 2.4, 2.6 TFT doesn't work at all !

Ok, after hundreds of trials I have discovered that pure command "RPNXY" (without this I,W,C letter) works but still it sends bytes continously as long as pen is pressed.

Can all of that be explained better ?

What's more, the touch field doesn't occupy the whole screen area but is square (dimension of shorter edge). Also it is not explained.

Read out coordinates have no the same zero origin point.

Well I can understand some limitations but why it is not CLEARLY mentioned ?

But still what about command "RPNXYW" because I would expect one set of data sent when pen is pressed and not sent anything else until released and pressed again !

Is it still possible to do it ?



RE:Touch panel in 2.4, 2.6 TFT doesn't work at all !

Don't send any data to display after commands "RPNXYx", otherwise, the display will cancel to send X,Y data back to you to avoid display lock up at I2C and SPI mode even not at UART.

RE:Touch panel in 2.4, 2.6 TFT doesn't work at all !

Yes, I DO NOT send anything after "RPNXYx" ! Just this simple command. The module doesn't send ANYTHING.

The only action I have achieved to observe was sending a train of bytes when I have sent "RPNXY" and nothing more.

Tell me accurately what EXACT bytes should I send, are they ASCII codes of letters R P N X Y W ??????

But if I send ESC 44 should I add extra byte "W" ? There are terrible discrepancies between life and manual, people waste

hell of time for idiotic experiments.


RE:Touch panel in 2.4, 2.6 TFT doesn't work at all !

What's more :

after sending "RPNXY" on pin PENIRQ there is constant action. Square wave with a period of 800us in idle state (panel not pressed.

After pressing it goes low as long as pressed. Then it returns to strange activity, so it can't be used for generating hardware interrupts

as it generates them all the time when panel is not pressed anymore ! To make it clear : I do NOT send at that time anything to module's Rx.

This line is at high state. What to hell is going on ?


I would like to achieve VERY SIMPLE action : at idle state module DOESN'T send anything. When panel is pressed it sends x,y coordinates

one time. That's all. Can you tell me how to do it ? Do I expect to much ?


RE:Touch panel in 2.4, 2.6 TFT doesn't work at all !

Hmmm, it looks that the only way to achieve the above is to send "RPNXY" and then after reading first coming 4 bytes to mask interrupts for let's say 500ms.

This way we can have one readout which can be repeated after masking time. But I still can't understand why command "RPNXYW" doesn't work.


Copyright Digole Digital Solutions, 2008-2021. All rights reserved.
Powered by Victor Sun