Search Forum.. 

OLED12864 some letters not displaying

Hello, I have a Digole OLED12864 - 0.96" Serial UART/I2C/SPI 128x64 OLED Module White CN

I am having a display problem with it.

Initially it was working fine. Now all of a sudden certain letters are not appearing.
All upper case and numbers are displaying fine.
With lower case, letters "a" to "m" display fine. Letter "n" displays partially corrupted - the bottom of it is whited out. The remaining letters - "m" to "z" do not display at all.
For example, if I send the word "water" to the display, it will instead say "ae". The w,t,r are stripped out.

The problem even shows when simply power is sent through it and it displays the "SPI:SS enable" initial screen. The "n" is corrupted. Or when I place it into UART mode it says "UART bad: 9600" (ie. lowercase "u" stripped out).
I have tried both UART and SPI modes, both have the same problem.

I tried updating the firmware using Coolterm, but I suspect this OLED unit is an older one that cannot be upgraded (purchased July 2013. Only started using it a few weeks ago). The "BLUBL}" command gets ignored.

Is there some way to fix this unit, or is it no good anymore?

Many Thanks.



RE:OLED12864 some letters not displaying

Happy New Year! 

If the internal fonts are corrupted on older module (for unable upgraded module), the only way is to use user fonts now, sorry about that.

RE:OLED12864 some letters not displaying

Thank you for the fast reply.

Could you please tell me where I can obtain some user fonts from?


RE:OLED12864 some letters not displaying

Copyright Digole Digital Solutions, 2008-2022. All rights reserved.
Powered by Digole