Search Forum.. 

Graphics works text don't

Using my 2" 320x240 in I2C with a Raspberry Pi, I interrup a program (Ctrl+C) during loading image (EDIM1) and I redo the program.
Since, graphics commands work and text commands don't !
Now I test it in serial with RealTerm.
At power on, everything good (alternated colors of white, red, green, blue) but no information about configuration.

If I send "TTHello world" + 0x00, nothing append ! Even if I chose a font before (SF0 for example).

If I send "FR" 0x00 0x00 0x50 0x50 a blanck square is draw at the right place.
Same thing with CL and BL commands

I try to update firmware as on but nothing append !
When I send "BLUBL}", the screen does not turn blanck and, just at the the beginning of sending the .hex file, the screen power on (alternated screens colors)

Wat append ? pre-installed fonts are disable ?
How to retreive pre-installed fonts ???

RE:Graphics works text don't

 You may erased the splash screen and disable the configuration showing, try to send:

"DC1" ----to enable configuration

"SC1" ----to set a none black color

Then try "TTHello World!" to see if this string display on the screen?

For upgrade firmware, you need download this file: 2IN_320240_NOFLASH_V42V.hex 

RE:Graphics works text don't

I try DC1, SC1 and TT but TT still does not work.

I try upgrade firmware with 2IN_320240_NOFLASH_V42V.hex file by "Hard" method :
Open com in 57600 bauds and short cut DATA to GND and "Resets" pins, a "S" appears on RealTerm, good.
I release DATA and RESET and then I send file by RealTerm in 57600 bauds and with 30ms on line delay.
At the end of the transfer, nothing append and, after switch off, switch on, the screen is still as described in my first pos.

I repeat the operations 3 times with the same result...

Thank you for your help.

RE:Graphics works text don't

Some clarification about my problem :

Software update : Using Coolterm and hard method, I see "S" on the Coolterm window and I send .hex file correctly. At the end, I only see some random white line on the screen.

Did the procedure work well ???


Command testing : All orders seem to work... except TT with some fonts

Font 0, 10, 18, 51, 120 : does not work (no display on the screen and the cursor does not move)

Font 6 : works !

Font 123 : only works with numbers


Any solution to repair my screen is welcome...

RE:Graphics works text don't

 Did you check on "use transmit line delay"? only input 30ms in the "Delay" box is not enough.

Also, if you connected TX on the display to RX on your UART, you don't need to use "Delay", just check on the "XON" as flow control

RE:Graphics works text don't

For all my tests to update, I use 30ms for line delay.

I test too Xon/Xoff (and RX) with the same result...

I think there is a problem right from the begenning of the transfer :

  • I use Hard method, DATA to GND and RESET : a S is printed on Coolterm window
  • I release DATA and RESET
  • I send 2IN_320240_NOFLASH_V42V.hex file
  • At the beginning of the transfer, the DIGOLE screen change like at power on (alternated colors of white, red, green, blue) and N is printed on Coolterm window !!!


RE:Graphics works text don't

If you see N, means the firmware file is not for your display.
I checked your orders, you ordered two 2" display module, one with 2MB flash and other without it, you need to use different firmware file to upgrade it:

2IN_320240_NOFLASH_V42V.hex  for No flash chip display

2IN_320240_FLASH_V42V.hex for 2" display with flash chip

Please re-download each file, then you supposed be upgrade them successful.

RE:Graphics works text don't

Yes, I have 2 display modules :

  • First without flash (empty "MEM" component and a micro SD slot). This is the one who as the problem.
  • Second with flash, received this week and work well. I do not do any update on this one !

So, for the first module (2" without flash and a micro SD slot), I use the 2IN_320240_NOFLASH_V42V.hex file.

I just tried it again, downloading the file again and... with the same result !

Just for fun, I tried the file 2IN_320240_FLASH_V42V.hex with the same result !

I olso tried version NOFLASH V40V, V40B and V39B with alway the same result !

So I do not have a solution to reload the right software.

RE:Graphics works text don't

 Redownload the latest firmware from Digole, remember to use correct firmware file, other wise, the display module will reject the accept the upgrading.

Copyright Digole Digital Solutions, 2008-2022. All rights reserved.
Powered by Digole